Autor Thema: ACPI-Version  (Gelesen 1513 mal)

streetrunner

  • Beiträge: 67
    • Profil anzeigen
Gespeichert
« am: 31. May 2013, 15:14 »
Hallo zusammen,

ich habe mir gestern ein paar Zeilen Code zusammengeschrieben/kopiert um mal zu sehen, ob ich den RSDP finde. Und siehe da, ich hatte Erfolg. Aber eins hat mich stutzig gemacht: Laut meinem Code ist die Version von ACPI bei Qemu = 0 (also Version 1). Wenn ich den Code auf meinem Rechner ausführe bekomme ich auch gesagt das Version 1 vorhanden ist. Nun ist mein Rechner zwar schon etwa 5 Jahre alt (X58 Board), aber Version 3-4 hätte ich da dann doch schon erwartet. Kann irgendwer diese Werte bestätigen (vllt. mit einem ähnlich altem Rechner) oder ist mein Code evtl. falsch???

Gruß,
Streetrunner

MNemo

  • Beiträge: 547
    • Profil anzeigen
Gespeichert
« Antwort #1 am: 01. June 2013, 10:54 »
Welchem Feld genau entnimmst du denn das es sich um ACPI 1.0 handelt. Dann kann ich das evtl. mal schnell nach gucken. Ist aber denke ich nicht ungewöhnlich, dass das die ACPI Versionen uralt sind. Falls es RSDP.revision ist, dann gibt es nur an welche Felder in der RSDP vorhanden sind. Wenn die Tabellen in den unteren 4 GiB gehalten werden brauchst du keine 64 Bit Adressen und revision 0 ist vollkommen ausreichend. Und lässt nicht auf die ACPI Version schließen.

Ich habe auch noch mal gerade nach einem neuen 120 € Mainbord geguckt, das Ding unterstützt laut Beischreibung sogar ACPI v1.0b ^^
„Wichtig ist nicht, besser zu sein als alle anderen. Wichtig ist, besser zu sein als du gestern warst!“

streetrunner

  • Beiträge: 67
    • Profil anzeigen
Gespeichert
« Antwort #2 am: 01. June 2013, 13:33 »
Danke für die Antwort.

Ich nehme wie du beschrieben hast das Feld RSDP.revision . Allerdings hatte ich erwartet dass dort schon die "richtige" Version drinne steht und nicht nur angegeben wird welche felder in der RSDP entahlten sind. Da ich aber in der Zwischenzeit weiter programmiert habe ist mir auch aufgefallen, dass jede Tabelle ihren eigenen Eintrag für die Version hat. Da habe ich mir schon sowas gedacht von wegen "jetzt muss ich für jede Tabelle die Version prüfen  :x".

Gruß,
Streetrunner

 

Einloggen