Autor Thema: Tester gesucht - die 0.2.2 steht an  (Gelesen 6930 mal)

kevin

  • Administrator
  • Beiträge: 2 767
    • Profil anzeigen
Gespeichert
« Antwort #20 am: 23. December 2009, 20:41 »
Hm, das ist interessant. Ich habe zwar ein paar Sachen im Kernel korrigiert, aber die hätten erst zum Tragen kommen können, wenn schon einmal Prozess beendet worden wäre - und dann wäre das System schon relativ weit gebootet. Insofern bin ich natürlich nicht unglücklich, dass es jetzt läuft, aber richtig erklären kann ich es mir nicht.

Es gibt vor allem noch Probleme mit dem FreePascal-Paket und dem iso9660-Treiber. Besonders die Crashes in letzterem hätte ich im Release gerne behoben, wenn es möglich ist.
Thou shalt not follow the NULL pointer, for chaos and madness await thee at its end.

Programm Noob

  • Gast
Gespeichert
« Antwort #21 am: 23. December 2009, 23:20 »
Wenn man sich überlegt, wie die fertigen Windows Versionen wenn sie rauskommen verbuggt sind, ist das doch wirklich sauber. also meiner Meinung nach kann Morgen releast werden.

Programm Noob

PS: PC geht jetzt auch, hab vorhin auch getestet.

Jidder

  • Administrator
  • Beiträge: 1 623
    • Profil anzeigen
Gespeichert
« Antwort #22 am: 23. December 2009, 23:48 »
Das "Start failed" erscheint nicht mehr.

Bei der Eingabe von IP/Gateway beim Start geht das Num-Pad nicht. CAPSLOCK AUCH NICHT! Oder kann es sein, dass das überhaupt nicht geht?

kirc hängt beim connecten, wenn man IP/Gateway nicht korrekt angegeben hat.

Der Boot vom CD-ROM-Laufwerk hängt immer noch nach dem [  INIT  ] service_register 'ata' = 3.
« Letzte Änderung: 23. December 2009, 23:51 von PorkChicken »
Dieser Text wird unter jedem Beitrag angezeigt.

kevin

  • Administrator
  • Beiträge: 2 767
    • Profil anzeigen
Gespeichert
« Antwort #23 am: 23. December 2009, 23:55 »
Bei der Eingabe von IP/Gateway beim Start geht das Num-Pad nicht. CAPSLOCK AUCH NICHT! Oder kann es sein, dass das überhaupt nicht geht?
Ja, letzteres. War wohl noch niemandem wichtig genug. ;)

Zitat
kirc hängt beim connecten, wenn man IP/Gateway nicht korrekt angegeben hat.
Normal sollte da nach etwa 10 Sekunden ein Timeout kommen.

Zitat
Der Boot vom CD-ROM-Laufwerk hängt immer noch nach dem [  INIT  ] service_register 'ata' = 3.
Hm, jo, das kann gut sein. Wir haben keine richtige Erkennung des Bootlaufwerks drin, sondern nehmen einfach das erstbeste ATAPI-Laufwerk als ata:/cdrom. Wenn du das im Bootmenü auf das CD-Laufwerk änderst (z.B. als ata:/atapi10, wenn es an Secondary Master hängt) sollte er auch davon booten. Oder es zumindest versuchen.
« Letzte Änderung: 24. December 2009, 00:13 von taljeth »
Thou shalt not follow the NULL pointer, for chaos and madness await thee at its end.

Jidder

  • Administrator
  • Beiträge: 1 623
    • Profil anzeigen
Gespeichert
« Antwort #24 am: 24. December 2009, 00:27 »
Jop, mit ata:/atapi11 hat er brav vom Secondary Slave gebootet.

Zitat
kirc hängt beim connecten, wenn man IP/Gateway nicht korrekt angegeben hat.
Normal sollte da nach etwa 10 Sekunden ein Timeout kommen.
Also wenn ich ihm 192.168.0.x-Adressen gebe, obwohl mein Netzwerk 192.168.1.x-Adressen hat, dann hängt er, aber wenn ich ihm falsche 192.168.1.x-Adressen gebe, dann gibt er mir zügig einen Fehler. Ich vermute das ist, weil die ARP-Anfrage aus Sicht des Routers fehlerhaft ist, und dieser deswegen nicht antwortet. (Zumindest deutet sich das im Log von Wireshark an, aber ich häng da halt auch nur als Client am Router. Keine Ahnung was wirklich beim PC ankommt.)

Edit: Vermutlich ist die Lage doch komplizierter, denn mit einigen fehlerhaften 192.168.1.x-Adressen hängt er auch ... Ich hab doch keine Ahnung von Netzwerk^^ (Er hängt nicht, wenn ich ihm fälschlicherweise einen anderen PC im Netzwerk als Gateway angebe.)

Hier noch die Meldung von kbc:
Zitat
kbc: Unbekannter Scancode: 0x7e (0)
kbc: Unbekannter Scancode: 0x7a (0)
« Letzte Änderung: 24. December 2009, 00:56 von PorkChicken »
Dieser Text wird unter jedem Beitrag angezeigt.

 

Einloggen