Autor Thema: UEFI Dualboot Windows + Linux  (Gelesen 3173 mal)

tiger717

  • Beiträge: 84
    • Profil anzeigen
Gespeichert
« am: 27. January 2013, 17:01 »
Hallo,

hat jemand zufällig ein funktionierendes UEFI-Dualboot-System mit Windows und Linux? Wenn ja, welcher Boot Manager und welche Distribution?

Ich verzweifle so langsam an meinem Häufchen Elend, dass hier vor mir steht. Situation wie folgt:
  • SSD 128GB (Samsung 830), gekauft 2012, für Windows, NTFS
  • HDD ~2TB (Hitachi irgendwas), gekauft 2012, für Windows als Datenplatte, 20GB Swap, Rest NTFS
  • HDD 500GB (Western Digital irgendwas), gekauft ~2010, für Linux, 100MB EFI Systempartition, 20GB Swap, 40GB Root, Rest Home
Mein MB ist ein Gigabyte GA-Z77-DS3H, Sockel LGA1155, dazu 16GB RAM.
Nun, als Linux sollte Arch und als Boot Manager rEFInd dienen, aber folgende Probleme:
  • Wenn ich Windows boote, wird der EFI-Booteintrag von rEFInd gelöscht - super.  :-D
  • Dasselbe passiert auch, wenn ich Windows von rEFInd aus boote.
  • Wenn ich (Arch) Linux boote, stürzt der PC bei "Start Setup Virtual Console" vollkommen ab, d.h. der Cursor blinkt nicht mehr (!). Zudem ist "Start Setup Virtual Console" eigentlich vollkommen trivial. (vconsole.conf auslesen)
  • Arch von der CD booten passt, ich kann die CD aber nicht im UEFI-Modus booten (irgendwas.conf fehlt angeblich)

Deshalb würde ich gerne wissen, unter welcher Konfiguration ihr Windows+Linux-UEFI-Dualboot zum laufen gebracht habt.

Grüße

PS: Ich wollte gestern unter hohem Aufwand meine ehemalige Konfiguration Windows unter BIOS (war damals meine Dummheit, sollt eigentlich gleich EFI werden) + Linux unter EFI in Windows unter EFI + Linux unter EFI umwandeln, was irgendwie nicht ganz hingehaun hat.
PPS: Das gewisse Windows ist Windows 8, bitte sagt mir jetzt keiner, dass es daran liegt, sonst könnt ich leicht... säuerlich auf MS und mich selbst werden.  :-D

XanClic

  • Beiträge: 261
    • Profil anzeigen
    • github
Gespeichert
« Antwort #1 am: 27. January 2013, 17:28 »
Das ist keine zum Thema wirklich beitragende Antwort, aber ich habe hier auch ein Z77-MB mit 16 GB RAM (was auch immer der zur Sache tut) und ich habe mich offenbar richtigerweise für BIOS-Emulation und GRUB (Legacy) entschieden. :3

Übrigens auch Arch, aber Windows 7.

Also, gibt es einen speziellen Grund, warum du UEFI willst? Außer, weil es geht?

tiger717

  • Beiträge: 84
    • Profil anzeigen
Gespeichert
« Antwort #2 am: 27. January 2013, 17:41 »
Das ist keine zum Thema wirklich beitragende Antwort, aber ich habe hier auch ein Z77-MB mit 16 GB RAM (was auch immer der zur Sache tut)
Falls sich jemand fragt, wozu ich 20GB Swap habe! :-D
und ich habe mich offenbar richtigerweise für BIOS-Emulation und GRUB (Legacy) entschieden. :3

Übrigens auch Arch, aber Windows 7.

Also, gibt es einen speziellen Grund, warum du UEFI willst? Außer, weil es geht?
Ich dachte, dass nach mehr als 2 Jahren UEFI-Entwicklung im Desktopbereich das Ganze einigermaßen klappen würde, aber das ist ja jetzt doch nicht der Fall...

Ich stehe also jetzt vor 3 Möglichkeiten:
  • Windows behalten, weiter an Arch/UEFI herumprobieren.
  • Beides unter BIOS neu installieren.
  • Arch als HyperV-VM installieren, gibts ja jetzt neuerdings als Zugabe zu Windows 8 Pro.

Martin Erhardt

  • Beiträge: 165
    • Profil anzeigen
Gespeichert
« Antwort #3 am: 27. January 2013, 18:31 »
Das ist keine zum Thema wirklich beitragende Antwort, aber ich habe hier auch ein Z77-MB mit 16 GB RAM (was auch immer der zur Sache tut)
Falls sich jemand fragt, wozu ich 20GB Swap habe! :-D
Swapping ist zwar sehr langsam, aber ich werde es wahrscheinlich trotzdem in meinem OS umsetzen weils ein cooles Feauture ist und aus Nostalgie (ohne Swapping würde heute niemand von Linux reden)

stultus

  • Beiträge: 486
    • Profil anzeigen
Gespeichert
« Antwort #4 am: 01. February 2013, 23:57 »
Bei mir läuft rEFInd einwandfrei - wenn er den Eintrag überschreibt würde ich da ne komische EFI-Firmware vermuten.
Was auszuprobieren wäre wäre der Workaround für andere Kaputtheiten (kann keine Einträge anlegen) -> den Win-Bootloader in der EFI-Bootpartition umbenennen und stattdessen rEFInd da hinsetzen (hängt nur am Dateinamen, wenn der ganze Crypto-krams erstmal aus ist) - den umbenannten Winloader kann rEFInd dann angeblich booten ohne dass da was zurückersetzt wird. Details im Arch-Wiki ;)
MSN: planetconquestdm@hotmail.de
ICQ: 190-084-185

... Wayne?

tiger717

  • Beiträge: 84
    • Profil anzeigen
Gespeichert
« Antwort #5 am: 07. February 2013, 17:08 »
Bei mir läuft rEFInd einwandfrei - wenn er den Eintrag überschreibt würde ich da ne komische EFI-Firmware vermuten.
Was auszuprobieren wäre wäre der Workaround für andere Kaputtheiten (kann keine Einträge anlegen) -> den Win-Bootloader in der EFI-Bootpartition umbenennen und stattdessen rEFInd da hinsetzen (hängt nur am Dateinamen, wenn der ganze Crypto-krams erstmal aus ist) - den umbenannten Winloader kann rEFInd dann angeblich booten ohne dass da was zurückersetzt wird. Details im Arch-Wiki ;)

Hmm, das wäre möglich gewesen.
Ich hätte deine Idee ausprobieren sollen, nur habe ich Arch Linux alleine (ich konnte es ja provisorisch booten, wurde nur dann eben überschrieben) nicht zum Laufen bekommen wegen eines Problems, das ich damals EFI zugeschrieben habe, aber eigentlich mit dem KMS zu tun hatte, wie ich herausgefunden habe, als ich Arch neu als BIOS-MBR-Konfiguration installiert habe und das Problem fortbestand. (Lösung: xf86-video-modesetting (oder so) und nvidea bzw. xf86-video-nouveau installieren oder behelfsmäßig nomodeset (oder so) als Kernel-Option im Bootloader)
Wie gesagt, nun ist es wieder zu spät. Sollte ich jetzt nochmal installieren, wieder EFI? (Das wäre dann die 5. Neuinstallation Windows auf SSD  :-D )

Nun, Arch bootet, aber damit ist es nicht getan!   :-o
systemd hat seine Problemchen mit dhcpcd. Ich kann es manuell (mittels systemctl start <service>) wunderbar starten, aber beim Booten... Damit möchte ich euch aber nicht mehr quälen, das gehört jetzt ins Arch-Forum.  :-D

 

Einloggen