Autor Thema: qemu Kommando nicht gefunden  (Gelesen 4966 mal)

Savatage

  • Beiträge: 28
    • Profil anzeigen
Gespeichert
« am: 09. April 2016, 21:21 »
Hallo ihr alten Hasen,

hier ist ein unwissender Neueinsteiger in die Thematik, der zwar voller Elan ist, sich aber noch ein wenig schwer tut und hier auf Unterstützung hofft.

Zu meinem Problem:
Ich möchte mir gern meinen eigenen Kernel schreiben. Dazu halte ich mich an das Tutorial und bin jetzt bei Teil 4 - Hello World angekommen (https://www.lowlevel.eu/wiki/Teil_4_-_Hello_World). Probleme habe ich jetzt mit dem Testen meines "Kernels". Dazu steht im Tutorial:

"qemu kann ab Version 0.11 Multiboot-Kernel direkt laden. qemu -kernel kernel bringt unseren Kernel zur Ausführung und schreibt ein wunderschönes Hello World in die linke obere Ecke. "

Ich habe qemu 2.6 von http://wiki.qemu.org/Download heruntergeladen und mit

./configure --target-list=x86_64-softmmu
make
make install

installiert. Möchte ich jetzt den Befehl "qemu -kernel kernel" ausführen, heißt es das Kommando wird nicht gefunden.
Nach etwas rumgooglen habe ich raus gefunden dass der Befehl in den neueren Versionen irgendwie anders heißt. (https://wiki.ubuntuusers.de/QEMU/)  Ich bin mir allerdings sehr unsicher und bitte deswegen hier um eine kleine Hilfestellung und Erklärung bzgl. Qemu.

Vielleicht noch als Hinweis:
Ich spiele das ganze in einer Virtual Box auf Debian durch.

Gruß
Sava

Savatage

  • Beiträge: 28
    • Profil anzeigen
Gespeichert
« Antwort #1 am: 09. April 2016, 21:49 »
gelöst. Melde mich sicher bald mit neuen Problemen.

Hier die Lösung:
qemu-system-x86_64 -kernel kernel

 

Einloggen